Skip navigation
Contact Us
665 Views 1 Reply Latest reply: Sep 20, 2012 8:46 AM by Joshua Vaughn RSS
Peri Bhavanam Newbie 3 posts since
Feb 24, 2009
Currently Being Moderated

Sep 19, 2012 8:01 PM

Informatica Replication Jobs [ Delta Load] are Failing for Which SQL User has Limited Priviliges on The database tables, no metadata changes in Salesforce nor database .

Hi All

 

Informatica Replication Jobs[ Salesforce to SQL Server] are failing [ Set up for Incremental Load], These Jobs were Working till 19-Sep-2012 6:30 AM EST time, All of a sudden the Jobs are failing even there is neither metadata changes in Salesforce nor in SQL Server.

 

Our Replication Job is a single task set to load all Object's for replication without Full Control to the SQL User. I tried doing metadata changes after i See this issue by Giving Alter previliges for first table then it truncated the first table and trying to truncate second object. Since SIT is going on I couldn't able to dare to do the database level changes to replicate everyhting freshly and I tried the below option. to check whether Workaround solution testing

 

1. Created a new mapping only for One Object[ User]

2. Given All Privileges to the SQL User.

3. Executed the Job.

4. Data Loaded successfully.

5 Revoked the Alter Privilege for SQL User.

6. Re-Executed the Job

7. No Change in Behavior . Still Job is failing.

 

I have given up and awaiting for the Support Guys to help me.

 

If anyone have this bad experience - appreciate if you guys can help, this is very critical and we are very near to Go-Live.

 

 

Thanks In Advance, for any help o suggestions.

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points