Skip navigation
Contact Us
14596 Views 8 Replies Latest reply: Mar 9, 2012 12:43 AM by Vinoop Nair RSS
Paritosh Sharma Newbie 2 posts since
Mar 2, 2011
Currently Being Moderated

Mar 2, 2011 2:11 AM

Issue while installing informatica 8.6.0

Hi All,

 

While i am installing informatica powercenter 8.6.0 after the domain configuration and while doing the node cinfiguration i am getting the following error :-

 

Cannot start Informatica services.

 

Use the error below and catalina.out and node.log in the server/tomcat/logs directory on the current machine to get more information. Select Retry to continue the installation.



EXITCODE: S

 

my operating system is windows 7 (32 bit).

 

Oracle version is Oracle 10g.

 

Thanks in advance for helping me to resolve this error.

 

-Paritosh

 

 


Attachments:
  • Thilakkumar N Novice 34 posts since
    Feb 15, 2011
    Currently Being Moderated
    Mar 2, 2011 3:01 AM (in response to Paritosh Sharma)
    Issue while installing informatica 8.6.0

    Hi,

     

    You cant install informatica in windows 7 as its not Compatible with this OS.


    You can try one alternative way which was posted earlier here but i am not 100 % sure of that solution.

     

    Before re installing the software, first change the compatability mode on install.exe. 
    Right mouse click on install.exe and then go to properties and then check for compatability tab and
    change the compatability to Windows XP Service packs 2 or Windows 2000 , where ever it is and click ok.

     

    let me know if it works fine.

     

    Thanks,

    Thilak

  • akash kumar Newbie 5 posts since
    Mar 7, 2011
    Currently Being Moderated
    Mar 7, 2011 3:35 AM (in response to Paritosh Sharma)
    Issue while installing informatica 8.6.0

    Hi,

         Yes Adil is correct.

  • sunil nandipati Newbie 1 posts since
    Mar 19, 2011
    Currently Being Moderated
    Mar 19, 2011 10:03 PM (in response to Paritosh Sharma)
    Issue while installing informatica 8.6.0

    Paritosh.  It is possible to install 8.6.0 on Windows 7 with Oracle 11g.

     

    Tomcat services are not running on your PC, so catalina related error.  Install apache tomcat from

    http://tomcat.apache.org/download-70.cgi - use the installer option

     

    Here are the things you might want to do.  I had a 15 day fight over my PC and I successfully Installed the demon on the damn secured Windows 7 - 32 bit(earlier vista upgraded to 7).

     

    Check you have these on your PC

     

    Java JRE (not the JDK)
    Apache Tomcat - Installed and Started (safe side)

    --------------------------------------------------------
    Core Problem to address

     

    The great windows vista and 7 are really too much security conscious
    Even though the user logged in as Admin, for some reason it restricts doing adminstrative tasks.
    So everytime you run something (an application) run it as an Administrator (right click on the application, change the compatability to Administrator and save.  And while running right click again and specifically run the program as Administrator)

     

    Safe side tweaks

    Right Click C drive and gave all permissions  to all users (since i was doing it on my personal PC)
    and reduce the UAC (User Account control) settings (find it at Control Panel\System and Security\Action Center)

    ---------------------------------------------------------
    Installation Procedure

    Ran the Program as Administrator in Windows XP Sp 2 mode
    Ran the install.exe rather than the bat as an administrator


    Informatica Installs the Informatica Services
    It tries to start the Informatica Services and tries to ping the domain.

    The services will not start.  So you get the famous and great error

     

    The installer cannot ping the domain.Verify that Informatica Services is running on the domain host and select Retry.

    STDOUT: [ICMD_10133] Command [ping] failed with error [[ICMD_10053] Node [node01_HAYAGRIV-PC] Domain [Domain_HAYAGRIV-PC] Host:Port [HAYAGRIV-PC:6001] has failed to ping back.].


    EXITCODE: -1

    Actually the infasrvcs.bat has instructions for the infasrvcs.exe to set the path, but for some reason bcoz of this damn security reasons, the path doesn't get set ... so you have to do it manually later and restart the services.

     

    Now the fix part

     

    1.  Say Ignore and finish the installation.
    2.  Right click on My Computer, navigate to properties, Environment Variables and ensure you have these variables declared

    i. JRE_HOME - ensure this has the path to your jre folder.
    ii. JAVA_HOME - ensure this has path to the folder where your java.exe is
    iii. PATH  - ensure the INFA\server\bin path is also included here (if not include it at the end with by clearly mentioning it with a ; for the previously existing path followed by your INFA\server\bin path)

    Now goto services.msc and restart the Informatica Services (Refresh and check they are running and not stopped)

    goto the admin console (Start -> Programs -> Informatica -> Services -> Admin Console)

    You should be good.

    Now ... even still if the Services are being stopped automatically, this is with the Firewall.

    Disable all the firewalls or add exceptions to the firewall to allow Port 6001 TCP communications
    Restart the system
    Restart the Informatica Services (Refresh and check they are running and not stopped)

    goto the admin console (Start -> Programs -> Informatica -> Services -> Admin Console)

     

    You should be good.

  • Vinoop Nair Novice 63 posts since
    Nov 27, 2011
    Currently Being Moderated
    Mar 9, 2012 12:43 AM (in response to Paritosh Sharma)
    Issue while installing informatica 8.6.0

    Infa 8.6 can be installed on windows 7. I have done it and works fine.

     

    For your error, add the informatica bin path to the PATH variable.

     

    Thanks,

    Vinoop

More Like This

  • Retrieving data ...

Bookmarked By (0)